Required packages

From Wiki Kaeilos.com
Jump to: navigation, search

Bash

KaeilOS build scripts need bash as default shell (/bin/sh) instead of dash.

sudo unlink /bin/sh
sudo ln -s /bin/bash /bin/sh

subversion

sudo apt-get install subversion

CVS

sudo apt-get install cvs 

git

sudo apt-get install git-core

libboost

sudo apt-get install libboost-date-time1.34.1 
sudo apt-get install libboost-filesystem1.34.1 
sudo apt-get install libboost-regex1.34.1

GNU Awk

sudo apt-get install gawk 

GNU CC

sudo apt-get install gcc

GNU G++

sudo apt-get install g++ 

GNU M4

sudo apt-get install m4 

GNU Make

sudo apt-get install make 

Patch

sudo apt-get install patch 

cchache

sudo apt-get install ccache 

Perl

sudo apt-get install perl 

Python

sudo apt-get install python

Python sqlite

sudo apt-get install python-sqlite

Python pysqlite2

sudo apt-get install python-pysqlite2

Psyco (Python Compiler)

sudo apt-get install python-psyco 

Diffstat

sudo apt-get install diffstat

help2man

sudo apt-get install help2man

texi2html

sudo apt-get install texi2html

texinfo

sudo apt-get install texinfo

uboot-mkimage

sudo apt-get install uboot-mkimage

build-essential

sudo apt-get install build-essential

Further details are available in OE wiki : http://wiki.openembedded.net/index.php/Required_Software

If you are not using Debian distro on your host machine, please read this : http://wiki.openembedded.net/index.php/OEandYourDistro